Partial Indexing Outage
Incident Report for Searchspring Public
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 06:58 MDT
Update
The customers affected by this issue are beginning to clear out, and we expect the indexing queue to drop back down to its normal size shortly. We are continuing to monitor to ensure that everything clears out as expected.
Posted Apr 06, 2021 - 12:02 MDT
Monitoring
We have migrated the affected indexing jobs to another cluster of servers, and are beginning to run indexing for the affected customers again. Affected customers may notice that the Index Status page seems to be stuck on the 'Waiting on Feed Generation' status for longer than normal until we're able to clear our queue out.

We're currently monitoring to ensure that the queue continues to clear out.
Posted Apr 06, 2021 - 11:48 MDT
Update
The performance issues should no longer be present. We are continuing to work on resolving the indexing issues and will provide another update within the next 15 minutes.
Posted Apr 06, 2021 - 11:36 MDT
Update
We are experiencing degraded performance on our Search, Recommendations, and Autocomplete API's related to the indexing failures. We expect these performance issues to be resolved shortly, and will provide an update within the next 15 minutes.
Posted Apr 06, 2021 - 11:25 MDT
Investigating
We are experiencing an issue that is causing any customer who requires Searchspring to create a data feed for them to not be able to queue their index. The affected customers will not be able to run index updates until we are able to correct the problem.
Posted Apr 06, 2021 - 11:12 MDT
This incident affected: Search, Indexing, Autocomplete, and Product Recommendation Widgets.