CORS issue
Incident Report for Searchspring Public
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 14:56 MDT
Monitoring
Due to a change rolled out by Shopify, requests to the Searchspring service started to fail. The Searchspring team created a patch to resolve the issue. We will continue to monitor the situation over the next hour to ensure all sites are operating as expected.
Posted Oct 01, 2021 - 13:02 MDT
Identified
We have addressed the reported issue with search and category pages but are still working on a fix for product recommendations. We will provide another update in 15 minutes.
Posted Oct 01, 2021 - 12:51 MDT
Update
A release was made by Shopify that adds new headers to the search request. These headers are not in our allowed list of headers so our API is rejecting them. We’re working on adding these headers to our allowed list temporarily to get things working again while we work with Shopify to determine why this change was made.

We will provide another update in 15 minutes.
Posted Oct 01, 2021 - 12:32 MDT
Update
We are continuing to investigate this issue.
Posted Oct 01, 2021 - 12:14 MDT
Investigating
We are currently investigating an issue that is affecting collection and search pages from loading for some Shopify customers. We will provide another update in 15 minutes.
Posted Oct 01, 2021 - 12:13 MDT
This incident affected: Search.