Degraded Search Performance
Incident Report for Searchspring Public
Resolved
The issue has now been resolved.
Posted Jun 03, 2024 - 12:47 MDT
Monitoring
We have identified and resolved the source of the issue.

We are now monitoring the situation the ensure normal performance continues.
Posted Jun 03, 2024 - 12:43 MDT
Investigating
We are currently experiencing an elevated number of errors related to our search API. This will impact some traffic in the North America region.

We are currently investigating and will provide regular updates in 30 minutes intervals or sooner.
Posted Jun 03, 2024 - 12:37 MDT
This incident affected: Search.