Major AWS Outage

Incident Report for Searchspring Public

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 05:58 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 05:55 MDT

Identified

AWS is currently having a major outage, this is impacting our indexing services https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 02:40 MDT
This incident affected: Indexing.